[UBUNTU 20.04] Accept vector alignment hints on z13 (binutils)

Bug #1889742 reported by bugproxy
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
binutils (Ubuntu)
Fix Released
Medium
William Wilson
Focal
Fix Released
Medium
William Wilson
Groovy
Fix Released
Medium
Unassigned

Bug Description

== Comment: #0 - Heinz-Werner Seeck <email address hidden> - 2020-07-31 03:28:30 ==
On z13 we have that vector alignment hints are already accepted. This backport enables GAS to accept such hints not only for target z14 but also for z13. Since GCCs default target on Ubuntu is z13 for s390x, we could greatly benefit from such alignment hints. (note a separate bugzilla entry for GCC allowing to emit alignment hints for z13 will be opened shortly)

This is a backport of upstreams commit 26b6ab7a0e.

Userspace tool common name: as

The userspace tool has the following bit modes: 64-bit

Userspace rpm: binutils

Already included within 20.10 via LP:
https://bugs.launchpad.net/ubuntu/+source/binutils/+bug/1888654

This should also be SRUed for 20.04

[Impact]

 * Vector alignment hints were enabled for z14 processors, but not z13

 * Since the z13 processors support vector alignment hints, binutils should
   have them enabled for z13

[Test Case]

 * Run the test suite to make sure all tests pass

 * Pull in the change, and re-run the test suite to make sure all
   tests still pass. This backport includes tests for the vector
   alignment hints.

[Where problems could occur]

 * If vector alignment hints were not enabled correctly we could still
   compile code with incorrectly ordered opcodes

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-187207 severity-medium targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

That#s a spin off of the already Fix Released ticket LP 1888654

affects: linux (Ubuntu) → binutils (Ubuntu)
Changed in ubuntu-z-systems:
importance: Undecided → High
Changed in binutils (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Canonical Foundations Team (canonical-foundations)
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Changed in binutils (Ubuntu Groovy):
status: New → Fix Released
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Changed in binutils (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: id-5f2438c76512db76f9b846d6
tags: added: fr-222
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: New → Triaged
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Triaged → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote :

I haven't looked at the debdiff in detail but the version number could use changing to ubuntu1.1 per https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update_the_packaging.

Revision history for this message
William Wilson (jawn-smith) wrote :
Revision history for this message
bugproxy (bugproxy) wrote : binutils_focal_sru.debdiff

Default Comment by Bridge

Mathew Hodson (mhodson)
Changed in binutils (Ubuntu):
importance: Undecided → Medium
Changed in binutils (Ubuntu Focal):
importance: Undecided → Medium
Changed in binutils (Ubuntu Groovy):
importance: Undecided → Medium
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Thanks for correcting the SRU version number.
I had to run update-maintainer to update maintainer fields.
Sponsored.

$ dput ubuntu binutils_2.34-6ubuntu1.1_source.changes
Checking signature on .changes
gpg: /tmp/binutils_2.34-6ubuntu1.1_source.changes: Valid signature from 9B8EC849D5EF70ED
Checking signature on .dsc
gpg: /tmp/binutils_2.34-6ubuntu1.1.dsc: Valid signature from 9B8EC849D5EF70ED
Uploading to ubuntu (via sftp to upload.ubuntu.com):
  Uploading binutils_2.34-6ubuntu1.1.dsc: done.
  Uploading binutils_2.34-6ubuntu1.1.debian.tar.xz: done.
  Uploading binutils_2.34-6ubuntu1.1_source.buildinfo: done.
  Uploading binutils_2.34-6ubuntu1.1_source.changes: done.
Successfully uploaded packages.

Changed in binutils (Ubuntu Focal):
status: New → In Progress
assignee: Canonical Foundations Team (canonical-foundations) → nobody
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Thanks for preparing the package and getting it uploaded. The diff and change seem to be fine, but since this is an upload to a toolchain package, we need to build it against -security (since these uploads go instantly to both -updates and -security, per policy). So I'll reject it from the queue and upload it to a -security enabled Bileto PPA:

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/4412

Once the builds finish there I'll perform a bin-sync to focal-proposed and accept it.

description: updated
Revision history for this message
Lukas Märdian (slyon) wrote :
Download full text (13.4 KiB)

All builds in ppa:ci-train-ppa-service/4412 finished and look good. Requesting bin-sync:

ubuntu-archive-tools$ ./copy-package -b --from ~ci-train-ppa-service/ubuntu/4412 -s focal -e 2.34-6ubuntu1.1 --to ubuntu --to-suite focal-proposed --sponsor jawn-smith binutils
Copy candidates:
 binutils 2.34-6ubuntu1.1 in focal
 binutils 2.34-6ubuntu1.1 in focal amd64
 binutils 2.34-6ubuntu1.1 in focal arm64
 binutils 2.34-6ubuntu1.1 in focal armhf
 binutils 2.34-6ubuntu1.1 in focal i386
 binutils 2.34-6ubuntu1.1 in focal ppc64el
 binutils 2.34-6ubuntu1.1 in focal riscv64
 binutils 2.34-6ubuntu1.1 in focal s390x
 binutils-aarch64-linux-gnu 2.34-6ubuntu1.1 in focal amd64
 binutils-aarch64-linux-gnu 2.34-6ubuntu1.1 in focal arm64
 binutils-aarch64-linux-gnu 2.34-6ubuntu1.1 in focal i386
 binutils-aarch64-linux-gnu 2.34-6ubuntu1.1 in focal ppc64el
 binutils-aarch64-linux-gnu-dbg 2.34-6ubuntu1.1 in focal amd64
 binutils-aarch64-linux-gnu-dbg 2.34-6ubuntu1.1 in focal arm64
 binutils-aarch64-linux-gnu-dbg 2.34-6ubuntu1.1 in focal i386
 binutils-aarch64-linux-gnu-dbg 2.34-6ubuntu1.1 in focal ppc64el
 binutils-alpha-linux-gnu 2.34-6ubuntu1.1 in focal amd64
 binutils-alpha-linux-gnu 2.34-6ubuntu1.1 in focal i386
 binutils-alpha-linux-gnu-dbg 2.34-6ubuntu1.1 in focal amd64
 binutils-alpha-linux-gnu-dbg 2.34-6ubuntu1.1 in focal i386
 binutils-arm-linux-gnueabi 2.34-6ubuntu1.1 in focal amd64
 binutils-arm-linux-gnueabi 2.34-6ubuntu1.1 in focal arm64
 binutils-arm-linux-gnueabi 2.34-6ubuntu1.1 in focal i386
 binutils-arm-linux-gnueabi 2.34-6ubuntu1.1 in focal ppc64el
 binutils-arm-linux-gnueabi-dbg 2.34-6ubuntu1.1 in focal amd64
 binutils-arm-linux-gnueabi-dbg 2.34-6ubuntu1.1 in focal arm64
 binutils-arm-linux-gnueabi-dbg 2.34-6ubuntu1.1 in focal i386
 binutils-arm-linux-gnueabi-dbg 2.34-6ubuntu1.1 in focal ppc64el
 binutils-arm-linux-gnueabihf 2.34-6ubuntu1.1 in focal amd64
 binutils-arm-linux-gnueabihf 2.34-6ubuntu1.1 in focal arm64
 binutils-arm-linux-gnueabihf 2.34-6ubuntu1.1 in focal armhf
 binutils-arm-linux-gnueabihf 2.34-6ubuntu1.1 in focal i386
 binutils-arm-linux-gnueabihf 2.34-6ubuntu1.1 in focal ppc64el
 binutils-arm-linux-gnueabihf-dbg 2.34-6ubuntu1.1 in focal amd64
 binutils-arm-linux-gnueabihf-dbg 2.34-6ubuntu1.1 in focal arm64
 binutils-arm-linux-gnueabihf-dbg 2.34-6ubuntu1.1 in focal armhf
 binutils-arm-linux-gnueabihf-dbg 2.34-6ubuntu1.1 in focal i386
 binutils-arm-linux-gnueabihf-dbg 2.34-6ubuntu1.1 in focal ppc64el
 binutils-common 2.34-6ubuntu1.1 in focal amd64
 binutils-common 2.34-6ubuntu1.1 in focal arm64
 binutils-common 2.34-6ubuntu1.1 in focal armhf
 binutils-common 2.34-6ubuntu1.1 in focal i386
 binutils-common 2.34-6ubuntu1.1 in focal ppc64el
 binutils-common 2.34-6ubuntu1.1 in focal riscv64
 binutils-common 2.34-6ubuntu1.1 in focal s390x
 binutils-dev 2.34-6ubuntu1.1 in focal amd64
 binutils-dev 2.34-6ubuntu1.1 in focal arm64
 binutils-dev 2.34-6ubuntu1.1 in focal armhf
 binutils-dev 2.34-6ubuntu1.1 in focal i386
 binutils-dev 2.34-6ubuntu1.1 in focal ppc64el
 binutils-dev 2.34-6ubuntu1.1 in focal riscv64
 binutils-dev 2.34-6ubuntu1.1 in focal s390x
 binutils-doc 2.34-6ubuntu1.1 in focal amd64
 binutils-doc 2.34-6ubuntu1.1 in focal arm6...

Changed in binutils (Ubuntu):
assignee: nobody → William Wilson (jawn-smith)
Changed in binutils (Ubuntu Focal):
assignee: nobody → William Wilson (jawn-smith)
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello bugproxy, or anyone else affected,

Accepted binutils into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/binutils/2.34-6ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in binutils (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-focal
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-02-05 08:07 EDT-------
A quick test has been done by compiling an assembler file which makes use of vector alignment hints for target z13 (the file was derived from the GCC testsuite s390/vector/align-1.c). The test was successful using binutils-2.34-6ubuntu1.1.

Thanks for the new binutils package! Now, only a GCC rebuild using the new binutils package is required in order to also emit vector alignment hints for z13 and later.

tags: added: verification-done-focal
removed: verification-needed verification-needed-focal
Frank Heimes (fheimes)
tags: added: verification-done
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (binutils/2.34-6ubuntu1.1)

All autopkgtests for the newly accepted binutils (2.34-6ubuntu1.1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

crash/7.2.8-1ubuntu1 (arm64)
python-debian/0.1.36ubuntu1 (armhf)
linux-gkeop/5.4.0-1009.10 (amd64)
linux-hwe-5.8/5.8.0-41.46~20.04.1 (ppc64el, amd64, s390x, arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#binutils

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package binutils - 2.34-6ubuntu1.1

---------------
binutils (2.34-6ubuntu1.1) focal; urgency=medium

  * Backporting upstream commit 26b6ab7a0e to accept vector alignment
    hints on z13 (LP: #1889742)

 -- William 'jawn-smith' Wilson <email address hidden> Thu, 21 Jan 2021 09:23:33 -0600

Changed in binutils (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for binutils has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-02-18 05:21 EDT-------
IBM Bugzilla status->closed, Fix Released with all requested distros

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers