[20.10 FEAT] Log FCP link EDIF capability - s390-tools part

Bug #1884773 reported by bugproxy
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
s390-tools (Ubuntu)
Fix Released
Undecided
Frank Heimes

Bug Description

A Linux on Z user can find out if an FCP remote port is accessed using authenticated or encrypted links, both in the running system, but also based on kernel logs.

Available with s390tools upgrade 2.13.0

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-186054 severity-high targetmilestone-inin2010
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (fheimes)
affects: linux (Ubuntu) → s390-tools (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

Even if the s390-tools 2.13 are already upstream released (https://github.com/ibm-s390-tools/s390-tools/releases/) we will probably directly jump to 2.14, since 2.14 is the version that fits to the groovy target kernel 5.8.
Hence this ticket is done once LP 1884721 is completed.

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Changed in s390-tools (Ubuntu):
status: New → Triaged
assignee: Skipper Bug Screeners (skipper-screen-team) → Frank Heimes (fheimes)
tags: added: id-5ef258945036f4125e000400
Changed in s390-tools (Ubuntu):
status: Triaged → In Progress
information type: Private → Public
Revision history for this message
Frank Heimes (fheimes) wrote :

(Well, could also be marked as duplicate of 1884721, since it's covered by that - anyway ...)

Changed in ubuntu-z-systems:
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.14.0-1ubuntu1

---------------
s390-tools (2.14.0-1ubuntu1) groovy; urgency=medium

  * Merge from Debian, remaining changes:
    - add libssl-dev, libglib2.0-dev build-deps
    - add support for signed zipl
    - package cpuplugd, osasnmpd, statd, zkey
    - update copyright file
    - fix kernel installer script integration, to skip calling zipl without initrd
    - load monwriter kernel module for mon_statd/mon_fsstatd
    - do not run dumpconf in lxc
    - ziomon change exit code to 0 for version and help
    - add zkey initramfs hook
    - change zkey default back to argon2i
    - drop patch that disables building osasnmpd
    - drop udevpath patch to init script, systemd units are used instead
    - enable hardening
    - enable initramfs & dracut integration
    - install more utilities and zdev initramfs integration
    - setup users/groups for mon_*, iucvterm, zkey
    - setup crashkernel integration
    - ship zdev in udeb
    - drop ziomon package, shipped in the main package

  * New upstream release fixes LP: #1892350, LP: #1888231, LP: #1884773,
    LP: #1884744, LP: #1884721

s390-tools (2.14.0-1) unstable; urgency=medium

  * New upstream release.

s390-tools (2.3.0-2) unstable; urgency=medium

  * Hardcode perl dependency instead of using ${perl:Depends}.
    The latter introduces a multi-arch dependency (perl:any) that the
    base installation environment cannot cope with.

 -- Dimitri John Ledkov <email address hidden> Wed, 26 Aug 2020 11:11:23 +0100

Changed in s390-tools (Ubuntu):
status: In Progress → Fix Released
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: In Progress → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2020-09-01 02:33 EDT-------
IBM Bugzilla status->closed, Fix Released with groovy

tags: added: fr-582
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers