No sound in ubiquity-dm with nomodeset

Bug #1901043 reported by Jean-Baptiste Lallement
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Fix Released
Undecided
Unassigned
ubiquity (Ubuntu)
Fix Released
Medium
William Wilson
Focal
Fix Released
Medium
William Wilson
Groovy
Won't Fix
Medium
Unassigned

Bug Description

[Impact]

 * When booting to "Safe Graphics" mode the system startup sound would
   sometimes not be played

 * This is an accessibility issue as the system startup sound is meant to
   indicate that Ubiquity is ready

[Test Case]

 * Boot an installer image to Safe Graphics mode and listen for the sound

 * You can optionally use `systemctl status sound.target` to monitor when the
   sound should be played. This should occur shortly after sound.target becomes
   active

[Where problems could occur]

 * If sound.target never comes up, the system ready sound will not be played.
   This could be caused by a missing or broken sound card

[Other Info]

 * It is expected behavior that the sound target may take longer to become active
   when nomodeset is on the kernel command line. This is because nomodeset prevents
   the kernel from pre-loading audio drivers.

 * This problem seems to be more prevalent with Intel sound cards

[Original Description]

Ubuntu Groovy Desktop

There is no sound in ubiquity-dm with nomodeset (safe graphics mode)

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: ubiquity 20.10.13
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
CasperMD5CheckResult: pass
CasperVersion: 1.455
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 22 15:20:00 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed maybe-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
Iain Lane (laney)
tags: added: rls-hh-incoming
Changed in ubuntu-release-notes:
status: New → Fix Released
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1901043

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
tags: added: fr-942
tags: removed: rls-hh-incoming
Revision history for this message
William Wilson (jawn-smith) wrote :

While trying to recreate this bug I found that the sound takes about 15-20 seconds to activate with nomodeset. The initial chime is missing but audio starts working shortly after. Is that consistent with what you observed?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Revision history for this message
William Wilson (jawn-smith) wrote :

Attached is an SRU for focal.

Changed in ubiquity (Ubuntu Focal):
milestone: none → ubuntu-20.04.2
Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
William Wilson (jawn-smith) wrote :

[Impact]

 * When booting to "Safe Graphics" mode the system startup sound would
   sometimes not be played

 * This is an accessibility issue as the system startup sound is meant to
   indicate that Ubiquity is ready

[Test Case]

 * Boot an installer image to Safe Graphics mode and listen for the sound

 * You can optionally use `systemctl status sound.target` to monitor when the
   sound should be played. This should occur shortly after sound.target becomes
   active

[Where problems could occur]

 * If sound.target never comes up, the system ready sound will not be played.
   This could be caused by a missing or broken sound card

[Other Info]

 * It is expected behavior that the sound target may take longer to become active
   when nomodeset is on the kernel command line. This is because nomodeset prevents
   the kernel from pre-loading audio drivers.

 * This problem seems to be more prevalent with Intel sound cards

Mathew Hodson (mhodson)
Changed in ubiquity (Ubuntu Focal):
importance: Undecided → Medium
Revision history for this message
William Wilson (jawn-smith) wrote :

This SRU for focal resolves the issue of being unable to connect to the system bus in schroot environments.

Revision history for this message
William Wilson (jawn-smith) wrote :

Attached is an SRU for groovy.

Revision history for this message
Brian Murray (brian-murray) wrote :

I've uploaded the focal debdiff so we can try and get this in on the 20.04.2 media.

description: updated
Revision history for this message
Iain Lane (laney) wrote : Re: [Bug 1901043] Re: No sound in ubiquity-dm with nomodeset

On Thu, Jan 28, 2021 at 11:00:24PM -0000, Brian Murray wrote:
> I've uploaded the focal debdiff so we can try and get this in on the
> 20.04.2 media.

Brian, we have a Vcs for ubiquity which has branches for stable
releases. Could you please commit this change there?

If you're confident enough to give this to users on focal, then I think
it would be appropriate to upload to devel as well.

Cheers,

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Revision history for this message
William Wilson (jawn-smith) wrote :

This focal SRU adds more specific exception handling.

Changed in ubiquity (Ubuntu Focal):
status: New → Triaged
Changed in ubiquity (Ubuntu Groovy):
status: New → Triaged
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 21.04.7

---------------
ubiquity (21.04.7) hirsute; urgency=medium

  [ William 'jawn-smith' Wilson ]
  * Listen on systemd signals in order to wait for sound.target to come
    up before attempting to play the system ready sound (LP: #1901043)

 -- Brian Murray <email address hidden> Fri, 29 Jan 2021 09:57:20 -0800

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

I'm setting groovy to won't fix because we won't release any new image of Groovy.

Changed in ubiquity (Ubuntu Groovy):
status: Triaged → Won't Fix
Changed in ubiquity (Ubuntu):
assignee: nobody → William Wilson (jawn-smith)
Changed in ubiquity (Ubuntu Focal):
assignee: nobody → William Wilson (jawn-smith)
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello Jean-Baptiste, or anyone else affected,

Accepted ubiquity into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/20.04.15.11 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubiquity (Ubuntu Focal):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
William Wilson (jawn-smith) wrote :

The verification passed for focal. The following steps were taken for verification:

  1)boot to safe graphics mode
    a) observe that no startup sound is played
    b) `watch -n 1 'systemctl status sound.target'`
      1) wait for sound.target to become active
      2) observe that no startup sound is played after
         sound.target becomes active
  2) download source for ubiquity version 20.04.15.11
    a) copy the changed files gtk_ui.py and misc.py
       to a flash drive
  3) reboot to safe graphics mode
    a) add `break=init` to the kernel command line
    b) in the initramfs, copy gtk_ui.py and misc.py from the
       flash drive to the root/ file system
    c) exit initramfs and allow boot to continue
    d) once the boot process has finished, observe
       that no startup sound is immediately played
    e) `cat /proc/cmdline` to ensure that `nomodeset`
       is on the kernel command line
    f) `watch -n 1 'systemctl status sound.target'`
      1) the startup sound is played when sound.target
         becomes active. Success!

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Just to triple check: could you confirm if everything is working as expected using the current focal daily images? Those are being built using -proposed, so it has ubiquity 20.04.15.11 built-in.

http://cdimage.ubuntu.com/focal/daily-live/

Revision history for this message
William Wilson (jawn-smith) wrote :

Confirmed it is working as expected in the focal daily build image. Thanks for letting me know they were built using -proposed!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.04.15.11

---------------
ubiquity (20.04.15.11) focal; urgency=medium

  [ William 'jawn-smith' Wilson ]
  * Listen on systemd signals in order to wait for sound.target to come
    up before attempting to play the system ready sound (LP: #1901043)

 -- Brian Murray <email address hidden> Thu, 18 Feb 2021 16:27:38 -0800

Changed in ubiquity (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers