Reinstall Ubuntu fails with an existing ESP

Bug #1900722 reported by Jean-Baptiste Lallement
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Fix Released
Undecided
Unassigned
ubiquity (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Groovy 20201020

= Test Case =
1. Install Ubuntu Desktop, reboot and verify that the target system has a biosgrub partition and an ESP
2. Install a second time
3. In the partitioning page, select "Reinstall Ubuntu"
4. Press on continue

= Expected result =
User can continue with installation

= Actual result =
A warning is displayed stating the no ESP has been found. If the user proceeds with installation anyway, it hangs when removing conflicting filesystem's files.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :
summary: - Reinstall Ubuntu fails on MBR systems with an ESP
+ Reinstall Ubuntu fails with an existing ESP
Changed in ubuntu-release-notes:
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Thomas Szymczak (tszymczak) wrote :

I am also affected on Ubuntu MATE.

Revision history for this message
Thomas Szymczak (tszymczak) wrote :

Here is the workaround I employed:
1. Open the Disks app to determine which partition is the EFI partition. It will be labeled "EFI System" under "Partition type."
1. Instead of selecting "reinstall" and getting an error, select "something else" to get manual partitioning.
2. Make sure the partition that previously had Ubuntu on it is used, will be mounted at /, and will not be formatted.
3. Select that partition, click the "Change..." button and set "Use as" to "EFI System Partition" in the dialog box that pops up.
4. Click "Install Now." There should not be any error about the EFI partition not being found.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers