Questions

Ask a development question or answer others’ in our diverse Q&A section. For information about the DigitalOcean product, check out our Product Docs.

28,487 questions
Ask a Question
  • Account suspended randomly for 'violation of terms' with no explanation.

    Out of the blue we get an email from the “abuse” department telling us that we have triggered an investigation and telling us to reply to the email. We reply to the email only to be notified 20 minutes later that the ...
    No answers yet0 days agoBy 60b050886825-43dd-bf32-5c34e8DigitalOcean Accounts
  • .htaccess file is modifying automatically

    .htaccess file is modified automatically to its original file. I have the following is the .htaccess file uploaded on my server. SetEnv CI_ENV development #SetEnv CI_ENV production RewriteEngine On RewriteCond $1 !^(i...
    No answers yet0 days agoBy giftmytripsApache
  • Next Js Deployment Can't resolve components or missing export script

    I was following this https://docs.digitalocean.com/tutorials/app-nextjs-deploy/ both static and custom. Both lead to errors for me. For Staticit says "Missing script: “export” i know the export command is there, maybe...
    No answers yet0 days agoBy d94c8c4691d4-48e3-81b8-ad72acNext.js
  • Can I receive the 100$ free credit after signing up?

    I just started using Digitial Ocean (TODAY) and already created my first droplet, but now I noticed the free 100$ trial here: https://try.digitalocean.com/freetrialoffer/ Can I apply for the credit now? Thank you.
    No answers yet1 day agoBy TinySeaGreenAxolotlBillingGetting Started
  • Can App Platform access droplets resources?

    Hi, I have just started using App Platform and it works really great! But I was wondering can apps access resources in droplets using private IP? For example, I would like to host a CockroachDB cluster with droplets, ...
    No answers yet1 day agoBy alanko0511DigitalOcean App Platform
  • Any updates on a DC here in South Africa?

    Any updates on a DC here in South Africa? As we have AWS here (locations in Cape Town and Johannesburg, and recently in Nairobi, Kenya…) but really want to stick with DO! its been a few years and im sure you have enou...
    No answers yet1 day agoBy ReinhardtDigitalOcean
  • Is SFO2 pci compliant?

    Our droplet is hosted on the SFO2 server center. Is that center PCI compliant?
    No answers yet2 days agoBy philc46cff3f565024445e5e64Security
  • Broken Pipe from (IP add)

    I have set-up Django project which works just fine on my local. Then I have set a droplet on digitalocean and once I ran for testing the python manage runserver 0.0.0.0:8000 it ran fine if i try to visit the browser w...
    3 answers2 days agoBy bizmoduleDjango
  • How to fix broken permissions on /etc, Accidentally ran chmod -R 755 /etc Ubuntu

    I would just like to achieve enough functionality to transfer my Postgres database from this droplet to another one since /etc’s permissions are severely broken and I’ve been recommended by everyone to try and recover...
    2 answers2 days agoBy KayUbuntu
  • Check provision status of api created database cluster

    We are creating a database cluster from the api. That part works fine, but we need a way to check and be notified once the cluster is done provisioning so we can add the databases to it. We tried making a curl call to...
    1 answer3 days agoBy Garrett WeinbergDatabasesMongoDBNode.js
  • I am still waiting for $100 free credit to reflect in my account, instead I owe $3.14

    Hi, I registered my account and very impressed with the $100 credit as a kick start. I thought upon registration the $100 would be available. Now I already created the Project and deploy my droplet but still no Free $...
    2 answers3 days agoBy Chris BuysDigitalOcean Accounts
  • I entered my GitHub Education promo code, and got the message that it had already been used.

    I signed into DO with the GitHub account that had the GitHub Education pack. Copied my promo code, pasted it, and apparently it’s already been used…Why did this happen? Did I do something wrong? What should I do now?
    2 answers3 days agoBy boolwinkleBilling
  • Shared Network Storage

    I was wondering if there is a way to setup a non-droplet shared network storage. IE: an NFS storage that I can mount to 1 or more droplets.
    1 answer3 days agoBy keiichi25BackupsBlock StorageCentOS 8Networking
  • KeepAlived service running but does not executes the check haproxy script

    I have configured a failover load balancer, so that it acts as a backup whenever my primary goes down.So I have setup Keepalived that switches the floating virtual IP address to the other machine whenever it is unable...
    No answers yet4 days agoBy eb05f79f75e8-4c24-ad9a-82fa78HAProxyLoad Balancing
  • How to add multiples domains in jitsi instance

    I’m deploying an jitsi instance with one click app, and want to add more than one domain to my jitsi. I was trying to create a new site, and then point it to jitsi, but i’m stuck on certbot, when creating certificate ...
    1 answer4 days agoBy Davi PEnaNginxDigitalOcean 1-Click Apps Marketplace
  • [PM2][ERROR] Process or Namespace hello not found

    I am going through the initial guide for node.js. This is how it goes in the middle of the tutorial/setup/guide. SSH into your Droplet and modify this script at /var/www/html/hello.js and see the results live by calli...
    Accepted Answer: Better off following this as tutorial. https://marketplace.digitalocean.com/apps/nodejs
    2 answers4 days agoBy ShahrukhAhmedNode.js
  • How to login as root in App Platform console

    I want to install python locale languages so that my app will work with local language. The problem is that when i try to install it, console says that i have to login as a root. I tried to login with “sudo root” but ...
    2 answers4 days agoBy SmallLapisAnglerDigitalOcean App PlatformPython
  • How do I enable to access ssh server outside from App Platform?

    I got “ssh: connect to host x.x.x.x port 22: Operation timed out” in my app in App Platform. My app needs to execute commands on servers outside via ssh protocol.
    3 answers4 days agoBy immysecDigitalOcean App Platform
  • ERR_CONNECTION_REFUSED when i want to deploy a war file to tomcat

    Hi all, I downloaded tomcat in ubuntu and MySQL database so tomcat runs successfully with my server IP address and the port, and when I want to deploy the war file of my application it gives me “ERR_CONNECTION_REFUSED”
    1 answer5 days agoBy tselawe706APIDigitalOcean Cloud FirewallsFirewallInitial Server SetupUbuntu
  • How to get StrapiJS running as an API?

    Hello, i’m new to DigitalOcean and new to JS as a server language. I was triggered by an article, which shows an 1-click-deployment for strapiJS. Registered at DO, i could not find it, so i clicked an Ubuntu server, i...
    1 answer5 days agoBy KoljaLDeploymentStrapi